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1          Installation 

To install Street Smart for ArcGIS Pro, please perform the following steps: 

1. Street Smart for ArcGIS Pro can be installed from a disk or network location: 

• Copy the Add-In file to a (local) disk or network location. 

• Start ArcGIS Pro. 

• Select menu: Project ► Add-In Manager and select the Options tab. 

  

Add-In Manager, Options tab. 

• Click <Add Folder...>. Browse to the folder where the Add-In file is located and click 

<OK>. 

    

Browse to the folder where the Add-In file is located. 

  

 

• Close the Add-In Manager and restart ArcGIS Pro. 

• Select menu: Project ► Add-In Manager. 

• Check whether Street Smart for ArcGIS Pro is ‘Authenticated’. If the Add-In is 

‘Untrusted’, close the Add-In Manager, close ArcGIS Pro and install the certificate 
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‘thawte-intermediate-ca.cer’ first (which is made available together with this user 

manual). 

 

Add-In Manager, Add-Ins tab, check if Street Smart for ArcGIS Pro is ‘Authenticated’ or ‘Untrusted’. 

  

• To install the certificate, please perform the following steps: 

• Double-click on ‘thawte-intermediate-ca.cer’ to install the certificate. 

 

 

             Install the certificate. 

• Click on <Install Certificate...> to start the installation wizard for the certificate.  
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                                                    Certificate Import Wizard. 

 

• Click: <Next>, <Next>, <Finished> to complete the installation of the certificate. 

  

   

                      The certificate is successfully imported. 

• Start ArcGIS Pro. 

• Select menu: Project ► Add-In Manager. 

• Check if Street Smart for ArcGIS Pro is now ‘Authenticated’. You can then proceed to 

paragraph 2).  
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                        Add-In Manager, Add-Ins tab, check that Street Smart for ArcGIS Pro is now ‘Authenticated’. 

2. If you start ArcGIS Pro for the first time after installing the Add-In, you will be shown the 

agreement form. Mark ‘I have read and agree to the terms of use’ as checked and click 

<OK>. 

  

 

      Agreement form. 

  

3. Select the Project ► Street Smart menu. You will now open the window Street Smart for 

ArcGIS Pro. 
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       Street Smart menu 

4. Select the tab Configuration.  

5. If you use a proxy server, you can enable Use a proxy server and enter the data about your 

proxy server. 

    

                   Street Smart for ArcGIS Pro Add-In window, Configuration tab. 

6. If you are using a local installation, uncheck the base URL and the swf URL Use default 

option and enter the correct URLs at Location instead. 
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7. Select the Login tab. 

 

8. Now you can enter a Username and Password and click on button Log in to log in using 

Basic Authentication, or you can click "Log in with SSO" to log in using Single Sign On. 

• If the user chooses Basic Authentication and tries to log in using a username and 

password, they will receive a 'Login failed' notification if the username and/or password 

is incorrect. However, if everything is entered correctly, a new window will open, and 

they will receive a 'Login successful' notification 

  

  

• If the user chooses Single Sign On and tries to log in using the 'Log in with SSO' button, 

the Add-In will redirect them to the configured OAuth provider. 
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And then the user will be logged in and granted permissions to the Add-In. 

 

 

  

9. Login Form Behavior – Basic Authentication vs. Single Sign On 

• When Single Sign On is selected as the authentication method, the login form only 

shows the relevant fields (e.g., Single Sign On button, status message). 

• If Single Sign On is enabled, the fields for Basic Authentication (e.g., username, 

password) are hidden, providing a clean and intuitive user experience. 

• The UI dynamically adjusts based on the user's login method selection. 
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• When logged in using Basic Authentication, the Single Sign On with SSO button will be 

visible but disabled, ensuring clarity without allowing redundant authentication actions. 

2      How to use Street Smart for ArcGIS Pro 

  

− 2.1    Exploring and viewing Cycloramas in ArcGIS Pro 

2.1.1    How to show recording locations of Cycloramas 

1. Select Recent Recording Layer in the Street Smart tab.  

 

The selected Recent Recording Layer icon. 

2. In the Table of Contents of ArcGIS Pro a new layer will appear as shown in the figure 

below. Zoom in on the map to a zoom level of at least 1:2000 to see the recording locations 

on the map (provided there are recordings in the area). 

 

The layer with recordings in the Table Of Contents. 

2.1.2    How to configure the Cyclorama viewers  

1. Select in the Table of Contents the map, right click on the mouse button ► Properties 

menu. You will now open the window Map Properties. 



 

Street Smart for ArcGIS Pro User Manual 

© 2024 CycloMedia Technology B.V.     |  11 

 

2. Select the Street Smart tab. 

 

Cyclorama viewing settings in the Street Smart tab. 

3. Select the coordinate system which the viewer(s) should use. 

4. Select the coordinate system which the Recording layer should use. 

5. Select overlay draw distance of overlays (in meters) 

6. Press <OK> for the changes to take effect.  

  

2.1.3    How to open Cycloramas 

  

1. Select the Open Location Tool in the Street Smart toolbar. 

  

The selected Open Location Tool icon. 

2. Click on a dot for the corresponding Cyclorama to open in a Cyclorama viewer. 

3. Click on another dot with shift-pressed and a second Cyclorama will open. 
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4. If the shift key isn’t pressed, the first Cyclorama will be replaced by the second Cyclorama.  

 

 

Street Smart for ArcGIS Pro with two Cyclorama viewers opened.(shift-click) 

− 2.2    Cyclorama Overlays Visibility Synchronization 

New configuration option (Keep overlays visibility in sync with map view) has been added to allow 

users to control whether Cyclorama overlays stay in sync with the map view or not. 
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How it works 

1. By Default (Sync Enabled): 

• When a new project is opened, the overlays visible in Cyclorama will be the same as those 

visible in the map. 

• Users can change the visibility of overlays in Cyclorama, but if they close and reopen the 

project, the visibility will resync with the map unless desynced. 

2. When Sync is Disabled (Checkbox Unchecked): 

• Overlays will not automatically follow the map layer visibility. 

• Once a user modifies the visibility of overlays, those preferences will be saved and 

remembered across project sessions. 

• This desync may improve performance, particularly in projects with many layers, as only 

relevant overlays will be displayed. 

Street Smart Toolbar Button (Sync the visibility): 

• An override button will be added to the Street-Smart toolbar, next to the Recording layer 

button. 

• This button allows users to override the synchronization setting at the project level. 

• The override button will function as a shortcut, enabling or disabling the sync for that 

specific project, allowing for greater flexibility.  

− 2.3    How to show vector data in Cycloramas 

1. Add one of the various types of vector data to the Table of Contents, such as: 

• Shapefiles 

• ArcSDE 

• Personal MDB 

• File GDB 
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2. Open a Cyclorama. Note that the vector data will now be shown in the Cycloramas.  

 

Showing vector data as overlay in the Cyclorama viewers. 

3. Optionally, set the distance at which vector layer data is displayed in the Map Properties ► 

Street Smart menu. The default distance is 30 meters, which means only vector data 

located within 30 meters of the recording location will be displayed. 

  

− 2.4    Performing measurements 

Measurements are stored in vector data layers. Point, line or surface measurements each are stored 

in separate point, line or polygon vector data layers. The following sections explain in detail how to 

perform the various types of measurements. To illustrate the principle of measuring, this manual will 

guide you through the process of performing standard measurements first, before explaining 

measuring with Smart Click (which is turned on by default). 

− Point measurement 

− Line / surface measurement 

Point measurement 

1. Add a point vector data layer to the map to store the measurement(s). 

2. Open a Cyclorama in which the object to measure is clearly visible. 

3. Select the tab: Edit ► Create to start editing mode in ArcGIS Pro. 
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                          Start editing mode in the newly added vector layer. 

4. Select the point layer in the Create Features window to start a point measurement. 

  

The Create Features window with several vector layers. 

 

 

 

 

5. You can select the measure method in the Cyclorama (Measure Smart / Smart Click / 

Forward intersection) 

 

The Measure mode bar 
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6. Select the point you want to measure in the Cyclorama. 

 

 

Performing a point measurement. 

  

7. It is possible to change the measurement now. If the measurement is correct, you can 

proceed to point 8. 

8. When you are finished with the measurement, click the <Location> button in the top of the 

Measurement mode bar. 

9. When you are finished with your measurements, save the edits to the vector layer in the 

Edit tab in ArcGIS Pro, as shown in the figure below.  
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Save edits in ArcGIS Pro. 

 

   Line / surface measurement 

 

1. Add a line or a polygon vector data layer to the map to store the measurement(s). 

2. Open a Cyclorama in which the object to measure is clearly visible. 

3. Select the tab: Edit ► Create to start editing mode in ArcGIS Pro. 

4. Select the line or polygon layer in the Create Features window to start a line or a surface 

measurement. 

5. You can select the measure method in the Cyclorama (Measure Smart / Smart Click / 

Forward intersection) 

6. Select the point you want to measure in the Cyclorama. 

7. Then select the second and subsequent points you want to measure, until you have 

selected all the points you want to measure. 

  

        Select all the points in the first Cyclorama step by step. 

8. It is now possible to edit points if this is desirable. 

9. When you are finished with the measurement, click the <Close> button in the bottom of the 

Selected Measurement Details window. 

10. Click on the Finish Sketch button on the toolbar in the map or the <Surface> button in the 

measure bar in the cyclorama. With one of these buttons, you can close the measurement. 
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         Use Finish Sketch on the toolbar of the bottom of the screen to close the measurement. 

11. When you are finished with your measurements, save the edits to the vector layer in the 

Edit tab in ArcGIS Pro 

 

 

                    After selecting the points in the second Cyclorama, the measurement is complete. 

 

How to import a measurement in a Cyclorama 

 

1. Select the Move or Vertices option in the Edit tab. 

  

 

The Edit tab.  
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2. Select a feature on the map to select the overlay of the measurement in the Cyclorama. 

  

 

Selected overlay in the Cyclorama. 

  

3. If you want to edit the (selected) feature, select the Vertices option in the Edit tab. 

 

  

 

Measurement shown in the Cyclorama (After use the Verticles option). 

 

4. It is now possible to edit the measurement in the Cyclorama or on the map. 

If you want to edit a measurement point in the Cyclorama, select that point in the map. 

−  2.5    Cyclorama search functionality 

  

1. To start the cyclorama search functionality, click on the ImageId Search button in the Street 

Smart tab. 

 

 

ImageId search button 

2. You will now see the ImageId search window. 
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Find Cyclorama window 

3. Enter an imageId and you will get the results 

4. Double-click the result and you go to the cyclorama. 

  

 

 

 

3   Supported Overlay Symbols 

Below is a list of the supported symbols in the overlays. 

  

The following renderers are supported: 

1. Single symbol renderer 

2. Unique value renderer 

  

The point Symbols: 

• Supported: 

 Circle symbols 

 Color (including transparency) 

 Stroke color (including transparency) 

 Stroke width 

 Picture marker symbols 

• Not supported: 

 Size 

• ArcGIS 2D symbols: 

 Supported: 
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 Circle symbols 

 Color (including transparency) 

 Stroke color (including transparency) 

 Stroke width 

 Picture marker symbols 

 Not supported: 

 All other styling and symbols 

• ArcGIS 3D symbols: not supported (the symbols are not displayed) 

  
The Line Symbols: 

• Supported: 

 Color (including transparency) 

• Not supported: 

 Line width 

• ArcGIS 2D symbols: 

 Supported: 

 Color (including transparency) 

 Not supported: 

 All other styling of the symbols 

• ArcGIS 3D symbols: 

 Supported: 

 Color (including transparency) 

 Not supported: 

 All other styling of the symbols 

  

The Polygon Symbols: 

• Supported: 

 Color (including transparency) 

• Not supported: 

 Outline 

 Outline color 

 Outline width 

• ArcGIS 2D symbols: 

 Supported: 

 Color (including transparency) 
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 Not supported: 

 All other styling of the symbols 

• ArcGIS 3D symbols: 

 Supported: 

 Color (including transparency) 

 Not supported: 

 All other styling of the symbols 
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